commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "jessy (JIRA)" <>
Subject [jira] [Commented] (COMPRESS-194) Unable to create a TAR file that contains an entry which is >8 GB in size.
Date Mon, 09 Jul 2012 10:04:35 GMT


jessy commented on COMPRESS-194:


I tried to setBigNumberMode to tarOutputStream.BIGNUMBER_STAR [ =1 ]. 
However, i found that tarring completes without any exceptions, and shows the tar archive
size as 9GB(which is my input of 9GB content file).
But ,when i tried to unzip( windows ), I was unsuccessful in opening this tar. Got the error
dialog "The archive is corrupt” 
When I tried to open the tar thru windows right click menu , I found my content file size
is 0 bytes. I have taken care to close all streams . 
I have attached my code snippet with this thread. 

Could you kindly look at my below code snippet and suggest what might be the rootcause for

> Unable to create a TAR file that contains an entry which is >8 GB in size. 
> ---------------------------------------------------------------------------
>                 Key: COMPRESS-194
>                 URL:
>             Project: Commons Compress
>          Issue Type: Bug
>          Components: Archivers
>    Affects Versions: 1.4.1
>         Environment: I am using win xp and Red HatLinux 5.1v, but this should be platform
>            Reporter: jessy
>            Priority: Critical
>             Fix For: 1.4
>         Attachments: tarImplntion.txt
> The common-compress-1.4.1 api says it supports unlimited file sizes for tar and untar
operations. []
> Only Untar operations on a file > 8GB is fixed,
> But creating a tar on a file >8GB is not working.
> When I try to do  " tarOutputStream.putArchiveEntry(archiveEntry); " 
> i get the below exception. 
> java.lang.RuntimeException: entry size '9633985364' is too big ( > 8589934591 )
> 	at org.apache.commons.compress.archivers.tar.TarArchiveOutputStream.failForBigNumber(
> 	at org.apache.commons.compress.archivers.tar.TarArchiveOutputStream.failForBigNumbers(
> 	at org.apache.commons.compress.archivers.tar.TarArchiveOutputStream.putArchiveEntry(
> Looking for a fix .. 

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


View raw message