commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sébastien Brisard (JIRA) <j...@apache.org>
Subject [jira] [Created] (MATH-791) GammaDistribution.getAlpha() and getBeta() are confusing
Date Mon, 21 May 2012 18:35:40 GMT
Sébastien Brisard created MATH-791:
--------------------------------------

             Summary: GammaDistribution.getAlpha() and getBeta() are confusing
                 Key: MATH-791
                 URL: https://issues.apache.org/jira/browse/MATH-791
             Project: Commons Math
          Issue Type: Improvement
    Affects Versions: 3.1, 4.0
            Reporter: Sébastien Brisard
            Assignee: Sébastien Brisard
            Priority: Minor


As discussed on the mailing list
{quote}
Some methods in {{o.a.c.m3.distribution.GammaDistribution}} are ill-named. Indeed, the class
javadoc explicitly refers to the Wikipedia page. In this page, the shape parameter is named
alpha and the scale parameter is 1 / beta
(inverse of beta), while in the current implementation, the shape parameter is named alpha,
and the scale parameter is named beta (not 1 / beta !!!). This might be confusing. Looking
at other web pages, I see there is apparently no consensus on the naming of shape and scale
parameters. The problem lies with the accessors, which are
{{double getAlpha()}}
{{double getBeta()}}

I think these accessors can lead to confusion. I would therefore propose to deprecate them,
and replace them with
{{double getShape()}}
{{double getScale()}}
{quote}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message