commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sebb (Updated) (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (COLLECTIONS-398) BoundedFifoBuffer could be simplified by keeping a count of the number of entries
Date Thu, 08 Mar 2012 00:16:57 GMT

     [ https://issues.apache.org/jira/browse/COLLECTIONS-398?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Sebb updated COLLECTIONS-398:
-----------------------------

    Attachment: COLLECTIONS-398.patch

Patch to replace "full" boolean with numEntries int.
                
> BoundedFifoBuffer could be simplified by keeping a count of the number of entries
> ---------------------------------------------------------------------------------
>
>                 Key: COLLECTIONS-398
>                 URL: https://issues.apache.org/jira/browse/COLLECTIONS-398
>             Project: Commons Collections
>          Issue Type: Improvement
>            Reporter: Sebb
>         Attachments: COLLECTIONS-398.patch
>
>
> BoundedFifoBuffer could be much simplified by keeping a count of the number of entries,
and dropping the boolean full.
> This would speed up size() and isEmpty() and isFull().

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message