commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sebb (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (COMPRESS-176) ArchiveInputStream#getNextEntry(): Problems with WinZip directories with Umlauts
Date Sat, 25 Feb 2012 14:39:48 GMT

    [ https://issues.apache.org/jira/browse/COMPRESS-176?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13216468#comment-13216468
] 

Sebb commented on COMPRESS-176:
-------------------------------

I have 7zip installed, and it reads the archive OK.

However, I don't think that proves anything, since the plain names are correct.

I guess we could look at the 7zip source code to see if it uses the extra fields.

A better test would be to create a zip file using a filename that cannot be represented in
CP437, i.e. only the extra field would show the correct name.
                
> ArchiveInputStream#getNextEntry(): Problems with WinZip directories with Umlauts
> --------------------------------------------------------------------------------
>
>                 Key: COMPRESS-176
>                 URL: https://issues.apache.org/jira/browse/COMPRESS-176
>             Project: Commons Compress
>          Issue Type: Bug
>          Components: Archivers
>    Affects Versions: 1.3
>         Environment: Windows 7
>            Reporter: Wurstbrot mit Senf
>         Attachments: test-7zip.zip, test-windows.zip, test-winzip.zip
>
>
> There is a problem when handling a WinZip-created zip with Umlauts in directories.
> I'm accessing a zip file created with WinZip containing a directory with an umlaut ("รค")
with ArchiveInputStream. When creating the zip file the unicode-flag of winzip had been active.
> The following problem occurs when accessing the entries of the zip:
> the ArchiveEntry for a directory containing an umlaut is not marked as a directory and
the file names for the directory and all files contained in that directory contain backslashes
instead of slashes (i.e. completely different to all other files in directories with no umlaut
in their path).
> There is no difference when letting the ArchiveStreamFactory decide which ArchiveInputStream
to create or when using the ZipArchiveInputStream constructor with the correct encoding (I've
tried different encodings CP437, CP850, ISO-8859-15, but still the problem persisted).
> This problem does not occur when using the very same zip file but compressed by 7zip
or the built-in Windows 7 zip functionality.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message