commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Luc Maisonobe (Commented) (JIRA)" <>
Subject [jira] [Commented] (MATH-707) Naming confusion
Date Wed, 08 Feb 2012 16:24:59 GMT


Luc Maisonobe commented on MATH-707:

I don't like the lack of symmetry for SimpleXxxValueChecker with respect to the point checkers.
If we want to go for simpler name, then we could probably also merge SimpleScalarValueChecker
and SimpleVectorialValueChecker into SimpleValueChecker<Object>.
> Naming confusion
> ----------------
>                 Key: MATH-707
>                 URL:
>             Project: Commons Math
>          Issue Type: Task
>            Reporter: Gilles
>            Assignee: Gilles
>            Priority: Trivial
>              Labels: api-change
>             Fix For: 3.0
> This issue was raised in [this thread|] on
the "dev" ML.
> It proposes to consistently name classes/interfaces that refer to number types (e.g.
"Real", "Complex", ...) and structure (e.g. "Scalar", "Vectorial", ...), with "Real" and "Scalar"
components in names being assumed (thus, not to be included in the name).
> For example, for the "Univariate..." interfaces (in package "analysis"), the proposal
is to operate the following renaming:
> * {{UnivariateRealFunction}} -> {{UnivariateFunction}}
> * {{UnivariateRealVectorialFunction}} -> {{UnivariateVectorFunction}}
> * {{UnivariateMatrixFunction}} -> {{UnivariateMatrixFunction}}
> Similar changes are in order in the package "optimization" (where "Real" is sometimes
included in the name and sometimes not, or used instead of "Scalar").

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


View raw message