commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gilles (Updated) (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (MATH-643) Rename RealVector.map* to RealVector.ebe* (mapAdd(...) to ebeAdd(...) and mapAddToSelf(...) to ebeAddToSelf(...) for instance
Date Wed, 08 Feb 2012 11:45:59 GMT

     [ https://issues.apache.org/jira/browse/MATH-643?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Gilles updated MATH-643:
------------------------

    Fix Version/s:     (was: 3.0)
                   4.0
    
> Rename RealVector.map* to RealVector.ebe* (mapAdd(...) to ebeAdd(...) and mapAddToSelf(...)
to ebeAddToSelf(...) for instance
> -----------------------------------------------------------------------------------------------------------------------------
>
>                 Key: MATH-643
>                 URL: https://issues.apache.org/jira/browse/MATH-643
>             Project: Commons Math
>          Issue Type: Improvement
>            Reporter: Arne Plöse
>            Priority: Minor
>             Fix For: 4.0
>
>
> I think the map* methods have historical names. Today I would prefer ebe as prefix like
ebeMultiply(...).
> This would describe the methods better from a users view.
> If this is a valid issue, I could provide a patch.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message