commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gilles (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MATH-707) Naming confusion
Date Wed, 08 Feb 2012 13:37:59 GMT

    [ https://issues.apache.org/jira/browse/MATH-707?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13203584#comment-13203584
] 

Gilles commented on MATH-707:
-----------------------------

In the "o.a.c.m.optimization" package, I propose to change the following:
* {{RealPointValuePair}} -> {{Pair<double[], Double>}}
* {{VectorialPointValuePair}} -> {{Pair<double[], double[]>}}
* {{SimpleRealPointChecker}} *and* {{SimpleVectorialPointChecker}} -> {{SimplePointChecker<P
extends Pair<double[], Object>>}}
where current instantiations will be replaced by
** {{SimpleRealPointChecker}} -> {{SimplePointChecker<Pair<double[], Double>>}}
** {{SimpleVectorialPointChecker}} -> {{SimplePointChecker<Pair<double[], double[]>}}
* {{SimpleScalarValueChecker}} -> {{SimpleValueChecker}}
* {{SimpleVectorialValueChecker}} -> {{SimpleVectorValueChecker}}

What do you think?

                
> Naming confusion
> ----------------
>
>                 Key: MATH-707
>                 URL: https://issues.apache.org/jira/browse/MATH-707
>             Project: Commons Math
>          Issue Type: Task
>            Reporter: Gilles
>            Assignee: Gilles
>            Priority: Trivial
>              Labels: api-change
>             Fix For: 3.0
>
>
> This issue was raised in [this thread|http://markmail.org/thread/4h6omyqsik65rcgv] on
the "dev" ML.
> It proposes to consistently name classes/interfaces that refer to number types (e.g.
"Real", "Complex", ...) and structure (e.g. "Scalar", "Vectorial", ...), with "Real" and "Scalar"
components in names being assumed (thus, not to be included in the name).
> For example, for the "Univariate..." interfaces (in package "analysis"), the proposal
is to operate the following renaming:
> * {{UnivariateRealFunction}} -> {{UnivariateFunction}}
> * {{UnivariateRealVectorialFunction}} -> {{UnivariateVectorFunction}}
> * {{UnivariateMatrixFunction}} -> {{UnivariateMatrixFunction}}
> Similar changes are in order in the package "optimization" (where "Real" is sometimes
included in the name and sometimes not, or used instead of "Scalar").

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message