commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sebb (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (COMPRESS-176) ArchiveInputStream#getNextEntry(): Problems with WinZip directories with Umlauts
Date Tue, 21 Feb 2012 15:08:37 GMT

    [ https://issues.apache.org/jira/browse/COMPRESS-176?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13212641#comment-13212641
] 

Sebb commented on COMPRESS-176:
-------------------------------

Thanks, but you have not granted the ASF licence to use the file, which means we cannot include
it in our test suite.

Please could you delete and reattach it?

Also, we will need the equivalent 7zip and Win7 archives for comparison.
                
> ArchiveInputStream#getNextEntry(): Problems with WinZip directories with Umlauts
> --------------------------------------------------------------------------------
>
>                 Key: COMPRESS-176
>                 URL: https://issues.apache.org/jira/browse/COMPRESS-176
>             Project: Commons Compress
>          Issue Type: Bug
>          Components: Archivers
>    Affects Versions: 1.3
>         Environment: Windows 7
>            Reporter: Wurstbrot mit Senf
>         Attachments: test-winzip.zip
>
>
> There is a problem when handling a WinZip-created zip with Umlauts in directories.
> I'm accessing a zip file created with WinZip containing a directory with an umlaut ("รค")
with ArchiveInputStream. When creating the zip file the unicode-flag of winzip had been active.
> The following problem occurs when accessing the entries of the zip:
> the ArchiveEntry for a directory containing an umlaut is not marked as a directory and
the file names for the directory and all files contained in that directory contain backslashes
instead of slashes (i.e. completely different to all other files in directories with no umlaut
in their path).
> There is no difference when letting the ArchiveStreamFactory decide which ArchiveInputStream
to create or when using the ZipArchiveInputStream constructor with the correct encoding (I've
tried different encodings CP437, CP850, ISO-8859-15, but still the problem persisted).
> This problem does not occur when using the very same zip file but compressed by 7zip
or the built-in Windows 7 zip functionality.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message