commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Claudio Squarcella (Updated) (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (SANDBOX-395) Correct names for classes and variables related to operations on weights
Date Mon, 20 Feb 2012 18:19:34 GMT

     [ https://issues.apache.org/jira/browse/SANDBOX-395?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Claudio Squarcella updated SANDBOX-395:
---------------------------------------

    Attachment: SANDBOX-395_CorrectClassAndVariableNamesForWeightOperations.patch

Hi,

I attach my proposed change as anticipated on mailing list. Note that:
* all base implementations of weight operations change names with the new pattern {{*BaseOperations}}
(e.g. {{DoubleWeight}} becomes {{DoubleWeightBaseOperations}});
* all weight-operation variables passed to algorithms and data structures change name from
the implemented interface (e.g. {{orderedMonoid}}) to {{weightOperations}}. To reflect this
also the generic type changes from {{OM}} to {{WO}};
* all comments, documentation and null-check strings are changed accordingly;
* in {{SuperVertex}} the {{Comparator}} needed for the operations is called {{weightComparator}}.


                
> Correct names for classes and variables related to operations on weights
> ------------------------------------------------------------------------
>
>                 Key: SANDBOX-395
>                 URL: https://issues.apache.org/jira/browse/SANDBOX-395
>             Project: Commons Sandbox
>          Issue Type: Improvement
>          Components: Graph
>            Reporter: Claudio Squarcella
>            Assignee: Claudio Squarcella
>            Priority: Minor
>              Labels: graph, operations, weight
>         Attachments: SANDBOX-395_CorrectClassAndVariableNamesForWeightOperations.patch
>
>
> Hi all,
> as discussed in ML already the current classes/variables that refer to operations on
weights can be renamed for better expressiveness:
> * all the classes under {{weight.primitive}} should be renamed from {{XXX}} to {{XXXOperations}}
because they actually contain operations on weights (they do not represent weights themselves);
> * in the actual algorithms, all variable names for weight operations should actually
be something like {{weightOperations}} instead of the name of the interface (e.g. {{orderedMonoid}}).

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message