commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Simone Tripodi (Commented) (JIRA)" <>
Subject [jira] [Commented] (SANDBOX-360) Rename Converter<T, S> to Transformer<T, S>
Date Fri, 20 Jan 2012 16:53:41 GMT


Simone Tripodi commented on SANDBOX-360:

I agree and like it, I was using the {{Converter}} keyword just because in the old API was
named in that way :P

Just the time to leave the office and once get back home, will be done :)
> Rename Converter<T, S> to Transformer<T, S>
> -------------------------------------------
>                 Key: SANDBOX-360
>                 URL:
>             Project: Commons Sandbox
>          Issue Type: Improvement
>          Components: BeanUtils2
>    Affects Versions: Nightly Builds
>            Reporter: Benedikt Ritter
>            Priority: Minor
> Since org.apache.commons.beanutils2.Converter is essentially a from of a Transformer
(see org.apache.commons.collections.Transformer), it should be named this way. The same applies
for org.apache.commons.beanutils2.converters.AbstractConverter<T,S>.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


View raw message