commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matt Benson (Commented) (JIRA)" <>
Subject [jira] [Commented] (SANDBOX-360) Rename Converter<T, S> to Transformer<T, S>
Date Fri, 20 Jan 2012 16:59:39 GMT


Matt Benson commented on SANDBOX-360:

The [collections] functors are all but deprecated; I wouldn't necessarily base other classes'
names on theirs.  I would argue that in a full-blown transformation framework e.g. Morph,
"transformer" is a generalization of "converter" and "copier".  My WIP object transformation
library (which might become Morph 2) uses this type of nomenclature as well.
> Rename Converter<T, S> to Transformer<T, S>
> -------------------------------------------
>                 Key: SANDBOX-360
>                 URL:
>             Project: Commons Sandbox
>          Issue Type: Improvement
>          Components: BeanUtils2
>    Affects Versions: Nightly Builds
>            Reporter: Benedikt Ritter
>            Priority: Minor
> Since org.apache.commons.beanutils2.Converter is essentially a from of a Transformer
(see org.apache.commons.collections.Transformer), it should be named this way. The same applies
for org.apache.commons.beanutils2.converters.AbstractConverter<T,S>.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


View raw message