commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sandro Lehmann (Updated) (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (LANG-781) Null-Check to variable Object parameters - ObjectUtils.isAnyNull
Date Thu, 05 Jan 2012 06:42:39 GMT

     [ https://issues.apache.org/jira/browse/LANG-781?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Sandro Lehmann updated LANG-781:
--------------------------------

    Description: Sometimes it would be very comfortable, to test a few objects to null. Instead
of writing if(obj1==null || obj2==null || ...), using a method like isAnyNull(obj1, obj2,
...) would be much better.  (was: Sometimes it would be very comfortable, to test a few objects
to null. Instead of writing if(obj1==null || obj2==null || ...), if there is a method like
isAnyNull(obj1, obj2, ...). It is much more readable.)
    
> Null-Check to variable Object parameters - ObjectUtils.isAnyNull
> ----------------------------------------------------------------
>
>                 Key: LANG-781
>                 URL: https://issues.apache.org/jira/browse/LANG-781
>             Project: Commons Lang
>          Issue Type: New Feature
>          Components: lang.*
>    Affects Versions: 3.1
>            Reporter: Sandro Lehmann
>            Priority: Minor
>              Labels: patch
>         Attachments: ObjectUtils.java.patch, ObjectUtilsTest.java.patch
>
>
> Sometimes it would be very comfortable, to test a few objects to null. Instead of writing
if(obj1==null || obj2==null || ...), using a method like isAnyNull(obj1, obj2, ...) would
be much better.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message