commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sébastien Brisard (Commented) (JIRA) <j...@apache.org>
Subject [jira] [Commented] (MATH-677) About package "transform"
Date Mon, 12 Dec 2011 07:26:31 GMT

    [ https://issues.apache.org/jira/browse/MATH-677?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13167390#comment-13167390
] 

Sébastien Brisard commented on MATH-677:
----------------------------------------

{{FastSineTransformer}} has been modified according to the above discussion in revision {{1213157}}.
* {{transform2()}} and {{inverseTransform2()}} have gone,
* constructors have been made private,
* two factory methods are provided {{create()}} and {{createOrthogonal()}}.
                
> About package "transform"
> -------------------------
>
>                 Key: MATH-677
>                 URL: https://issues.apache.org/jira/browse/MATH-677
>             Project: Commons Math
>          Issue Type: Improvement
>            Reporter: Gilles
>            Assignee: Sébastien Brisard
>            Priority: Minor
>              Labels: api-change
>             Fix For: 3.0
>
>
> Classes in package "o.a.c.m.transform" might require some changes in order to conform
to goals set for the next major release.
> Some observations:
> # Exceptions
> ## Should remove use of deprecated "MathRuntimeException"
> ## Should throw more specific "Math...Exception" instances instead of standard IAE
> # Interface "RealTransformer" (and implementations) contain non-conformant method names
(e.g. "inversetransform" instead of "inverseTransform"). {color:red}Fixed in {{r1208293}}.{color}
> # "FastFourierTransformer":
> ## Methods "mdfft" and "verifyDataSet" take an argument of type "Object" (to allow an
argument with an unspecified number of dimensions)
> ## The "RootsOfUnity" helper class could be moved to the "complex" package
> ## For clarity, multidimensional transform should be moved to a class of its own (and
I also wonder whether the "MultiDimensionalComplexMatrix" name is not misleading)
> # "FastFourierTransformer", "FastSineTranformer" and "FastCosineTranformer" define public
methods "tranform2" and "inversetransform2" but they are not part of an interface
> # Code uses variables that start with an uppercase. {color:red}Fixed, together with various
formatting issues.{color}
> # "FastHadamardTransformer" contains illegible developer documentation (see Javadoc for
protected method "fht"). {color:red}Tried to improve things in {{r1208986}}, but things are
still a bit obscure. Besides, the link provided is broken. Will look into that.{color}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message