commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From S├ębastien Brisard (Commented) (JIRA) <>
Subject [jira] [Commented] (MATH-677) About package "transform"
Date Wed, 30 Nov 2011 06:31:40 GMT


S├ębastien Brisard commented on MATH-677:

Regarding point 4., transform2 and inversetransform2 merely correspond to different normalization
conventions. Correct me if I'm wrong, the user is unlikely to use mixed conventions in the
*same* calculation (well, *I* never do!), maybe we could use parameterized constructors to
specify this normalization convention. In which case, {{transform2}} and {{inverseTransform2}}
could go.

Otherwise, we would need an altogether new interface, because the Hadamard transform does
not offer such a choice.

This option would also offer the possibility to implement other types of DCT/DST in the future.
This is just a thought, though, because in this case, maybe factory methods would be better.
> About package "transform"
> -------------------------
>                 Key: MATH-677
>                 URL:
>             Project: Commons Math
>          Issue Type: Improvement
>            Reporter: Gilles
>            Priority: Minor
>              Labels: api-change
>             Fix For: 3.0
> Classes in package "o.a.c.m.transform" might require some changes in order to conform
to goals set for the next major release.
> Some observations:
> # Exceptions
> ## Should remove use of deprecated "MathRuntimeException"
> ## Should throw more specific "Math...Exception" instances instead of standard IAE
> # Interface "RealTransformer" (and implementations) contain non-conformant method names
(e.g. "inversetransform" instead of "inverseTransform")
> # "FastFourierTransformer":
> ## Methods "mdfft" and "verifyDataSet" take an argument of type "Object" (to allow an
argument with an unspecified number of dimensions)
> ## The "RootsOfUnity" helper class could be moved to the "complex" package
> ## For clarity, multidimensional transform should be moved to a class of its own (and
I also wonder whether the "MultiDimensionalComplexMatrix" name is not misleading)
> # "FastFourierTransformer", "FastSineTranformer" and "FastCosineTranformer" define public
methods "tranform2" and "inversetransform2" but they are not part of an interface
> # Code uses variables that start with an uppercase
> # "FastHadamardTransformer" contains illegible developer documentation (see Javadoc for
protected method "fht")

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


View raw message