commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gary D. Gregory (Reopened) (JIRA)" <j...@apache.org>
Subject [jira] [Reopened] (DAEMON-219) prunsrv error 1067 and crash on Windows 7
Date Fri, 04 Nov 2011 16:17:52 GMT

     [ https://issues.apache.org/jira/browse/DAEMON-219?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Gary D. Gregory reopened DAEMON-219:
------------------------------------


I must be loosing my marbles. 

I am attaching a new version of the project that uses --StopClass and it still crashes on
service start up.

This is with 1.0.7.

Everything looks good on start up too:

{noformat}
[2011-11-04 12:11:28] [debug] ( prunsrv.c:1519) Commons Daemon procrun log initialized
[2011-11-04 12:11:28] [info]  (          :0   ) Commons Daemon procrun (1.0.7.0 64-bit) started
[2011-11-04 12:11:28] [info]  (          :0   ) Running 'Daemon219' Service...
[2011-11-04 12:11:28] [debug] ( prunsrv.c:1259) Inside ServiceMain...
[2011-11-04 12:11:28] [info]  (          :0   ) Starting service...
[2011-11-04 12:11:28] [debug] ( javajni.c:206 ) loading jvm 'C:\Program Files\Java\jdk1.6.0_29\jre\bin\server\jvm.dll'
[2011-11-04 12:11:28] [debug] ( javajni.c:660 ) Jvm Option[0] -Xrs
[2011-11-04 12:11:28] [debug] ( javajni.c:660 ) Jvm Option[1] -Djava.endorsed.dirs=C:\Users\ggregory\Documents\eclipse\LDE\Daemon-219\lde_home\lib\endorsed
[2011-11-04 12:11:28] [debug] ( javajni.c:660 ) Jvm Option[2] -Djavax.xml.transform.TransformerFactory=org.apache.xalan.xsltc.trax.SmartTransformerFactoryImpl
[2011-11-04 12:11:28] [debug] ( javajni.c:660 ) Jvm Option[3] -Dorg.apache.cxf.Logger=org.apache.cxf.common.logging.Log4jLogger
[2011-11-04 12:11:28] [debug] ( javajni.c:660 ) Jvm Option[4] -Djava.class.path=C:\Users\ggregory\Documents\eclipse\LDE\Daemon-219\lde_home\lib\daemon-219.jar
[2011-11-04 12:11:29] [debug] ( javajni.c:844 ) argv[0] = --config
[2011-11-04 12:11:29] [debug] ( javajni.c:844 ) argv[1] = C:\Users\ggregory\Documents\eclipse\LDE\Daemon-219\src\test\config
[2011-11-04 12:11:29] [debug] ( javajni.c:896 ) Java Worker thread started test/Daemon219StartService:main
{noformat}

The Event Log is not much help:

{code:xml}
 <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
  <Provider Name="Service Control Manager" Guid="{555908d1-a6d7-4695-8e1e-26931d2012f4}"
EventSourceName="Service Control Manager" /> 
  <EventID Qualifiers="49152">7034</EventID> 
  <Version>0</Version> 
  <Level>2</Level> 
  <Task>0</Task> 
  <Opcode>0</Opcode> 
  <Keywords>0x8080000000000000</Keywords> 
  <TimeCreated SystemTime="2011-11-04T16:11:29.114553200Z" /> 
  <EventRecordID>106250</EventRecordID> 
  <Correlation /> 
  <Execution ProcessID="700" ThreadID="9424" /> 
  <Channel>System</Channel> 
  <Computer>us-l-gg03.rocketsoftware.com</Computer> 
  <Security /> 
  </System>
- <EventData>
  <Data Name="param1">Daemon-219</Data> 
  <Data Name="param2">2</Data> 
  </EventData>
  </Event>
{code}

Then I get the same 1067 crash
                
> prunsrv error 1067 and crash on Windows 7
> -----------------------------------------
>
>                 Key: DAEMON-219
>                 URL: https://issues.apache.org/jira/browse/DAEMON-219
>             Project: Commons Daemon
>          Issue Type: Bug
>          Components: Procrun
>    Affects Versions: 1.0.7
>         Environment: Apache Maven 3.0.3 (r1075438; 2011-02-28 12:31:09-0500)
> Maven home: C:\Java\apache-maven-3.0.3\bin\..
> Java version: 1.6.0_24, vendor: Sun Microsystems Inc.
> Java home: C:\Program Files\Java\jdk1.6.0_24\jre
> Default locale: en_US, platform encoding: Cp1252
> OS name: "windows 7", version: "6.1", arch: "amd64", family: "windows"
>            Reporter: Gary D. Gregory
>            Assignee: Mladen Turk
>             Fix For: 1.0.8
>
>         Attachments: Daemon-219.zip, Daemon-219.zip, LdeServer3.reg, NoKey.PNG, SystemLdeService3.txt,
WER8D3F.tmp.WERInternalMetadata.xml, WERA3BC.tmp.appcompat.txt, WERA3BD.tmp.mdmp, commons-daemon.2011-10-03.log,
install-lde-service.cmd, ldeservice3-stderr.2011-10-03.log, ldeservice3-stdout.2011-10-03.log,
register.cmd, unregister.cmd
>
>
> I've defined attached cmd file on Windows 7 to install a service.
> I try to run the service with "prunsrv //TS/LdeService3" and I get "Commons Daemon Service
Runner has stopped working"
> Attaching all details.
> Is there more debug logging I can turn on? The current debug output seems minimal.
> This is probably a configuration user error but I cannot tell due to the lack of logging.
> Thank you.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message