commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gary D. Gregory (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DAEMON-219) prunsrv error 1067 and crash on Windows 7
Date Sat, 05 Nov 2011 03:05:53 GMT

    [ https://issues.apache.org/jira/browse/DAEMON-219?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13144538#comment-13144538
] 

Gary D. Gregory commented on DAEMON-219:
----------------------------------------

Thank you for your time Mladen. You've been a great help.

"But that means that the process has ended. It didn't crashed."

Ah, I did not realize that! There must have been other errors in my configuration that caused
my server to quit and do a System.exit(0). Our server does a System.exit on normal termination.
I've changed that so that my StopService class does not cause System.exit() to be called.

I can now do a 'net start' for my server service and it starts and can process requests including
a stop service request!

I found another bug in my set up: in a previous iteration I did not have a '*' at the end
of my classpath. I added it to the test example a while back which explains why the simple
test started working.

Now I need to find out why 'net stop' on my server service fails with:

{noformat}
System error 109 has occurred.

The pipe has been ended.
{noformat}

Any quick advice on this one? 

I hope you consider updating the documentation so that other users will avoid the traps I
fell in, especially the bit about --StopClass and System.exit().
                
> prunsrv error 1067 and crash on Windows 7
> -----------------------------------------
>
>                 Key: DAEMON-219
>                 URL: https://issues.apache.org/jira/browse/DAEMON-219
>             Project: Commons Daemon
>          Issue Type: Bug
>          Components: Procrun
>    Affects Versions: 1.0.7
>         Environment: Apache Maven 3.0.3 (r1075438; 2011-02-28 12:31:09-0500)
> Maven home: C:\Java\apache-maven-3.0.3\bin\..
> Java version: 1.6.0_24, vendor: Sun Microsystems Inc.
> Java home: C:\Program Files\Java\jdk1.6.0_24\jre
> Default locale: en_US, platform encoding: Cp1252
> OS name: "windows 7", version: "6.1", arch: "amd64", family: "windows"
>            Reporter: Gary D. Gregory
>            Assignee: Mladen Turk
>             Fix For: 1.0.8
>
>         Attachments: Daemon-219.zip, Daemon-219.zip, Daemon-219.zip, LdeServer3.reg,
NoKey.PNG, SystemLdeService3.txt, WER8D3F.tmp.WERInternalMetadata.xml, WERA3BC.tmp.appcompat.txt,
WERA3BD.tmp.mdmp, commons-daemon.2011-10-03.log, install-lde-service.cmd, ldeservice3-stderr.2011-10-03.log,
ldeservice3-stdout.2011-10-03.log, register.cmd, unregister.cmd
>
>
> I've defined attached cmd file on Windows 7 to install a service.
> I try to run the service with "prunsrv //TS/LdeService3" and I get "Commons Daemon Service
Runner has stopped working"
> Attaching all details.
> Is there more debug logging I can turn on? The current debug output seems minimal.
> This is probably a configuration user error but I cannot tell due to the lack of logging.
> Thank you.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message