commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sebb (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (LANG-778) Add UUIDUtils.toByteArray and UUIDUtils.fromByteArray
Date Wed, 23 Nov 2011 16:01:40 GMT

    [ https://issues.apache.org/jira/browse/LANG-778?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13155930#comment-13155930
] 

Sebb commented on LANG-778:
---------------------------

Since the methods must necessarily be inverses of each other, I think the current names are
not ideal.

toByteArray()
fromBytes()

I'd prefer either

toBytes/fromBytes
or
toByteArray/fromByteArray

but any other pairing that differs only by the to/from prefix would be fine.
                
> Add UUIDUtils.toByteArray and UUIDUtils.fromByteArray
> -----------------------------------------------------
>
>                 Key: LANG-778
>                 URL: https://issues.apache.org/jira/browse/LANG-778
>             Project: Commons Lang
>          Issue Type: New Feature
>          Components: lang.*
>            Reporter: Joerg Schaible
>            Assignee: Joerg Schaible
>            Priority: Minor
>         Attachments: LANG-778.diff
>
>   Original Estimate: 4h
>  Remaining Estimate: 4h
>
> A UUID represents 16 bytes. In some situation (e.g. using DBs that do not have native
support for the type UUID) it is necessary to use directly the bytes. The JDK does not support
the transformation from UUID to bytes and back, therefore I'd like to add UUIDUtils with the
two proposed methods.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message