commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sebb (Updated) (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (DAEMON-218) CLONE - procrun as tomcat5.exe from Tomcat 5.5.17 does not start, when installed into the file path containing non-ascii character
Date Thu, 03 Nov 2011 11:11:32 GMT

     [ https://issues.apache.org/jira/browse/DAEMON-218?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Sebb updated DAEMON-218:
------------------------

    Affects Version/s: 1.0.7
        Fix Version/s:     (was: 1.0.7)
                       1.0.8
    
> CLONE - procrun as tomcat5.exe from Tomcat 5.5.17 does not start, when installed into
the file path containing non-ascii character
> ----------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: DAEMON-218
>                 URL: https://issues.apache.org/jira/browse/DAEMON-218
>             Project: Commons Daemon
>          Issue Type: Bug
>    Affects Versions: 1.0.7
>            Reporter: Alexey Grishkov
>            Assignee: Mladen Turk
>             Fix For: 1.0.8
>
>         Attachments: prunsrv.c, utils.c
>
>
> Tomcat Service can not be started if Tomcat was installed into the path, 
> containing non-ASCII (e.g. Japanese or Chinese) symbols.
> The problem is apparently due to the improper treatment of non-ascii 
> characters in the "Java classpath" section of the Service settings.
> In tomcat5w.exe GUI or windows registry I could see proper PATH, namely
> C:\[ONE CHINESE HIEROGLIPH]\Tomcat 5.5\bin\bootstrap.jar
> Unfortunately, service doesn't get started with the following log:
> [2006-09-15 18:29:17] [457  javajni.c] [error] FindClass 
> org/apache/catalina/startup/Bootstrap failed
> [2006-09-15 18:29:17] [935  prunsrv.c] [error] Failed loading main 
> org/apache/catalina/startup/Bootstrap class C:\ss\Tomcat 5.5\bin\bootstrap.jar
> [2006-09-15 18:29:17] [1179 prunsrv.c] [error] ServiceStart returned 3
> where the non-ascii symbol gets replaced with improper ascii 'ss' sequence.
> Moreover, I tried to define environmental variables PR_CLASSPATH and 
> PR_STARTPATH instead of using corresponding service params. The result is 
> exactly the same.
> Please, suggest me the workaround to make Tomcat service run.
> P.S. The problem is stable either under JRE 1.5.0_02 or 1.4.2_10 (within 
> tomcat compatibility package). The problem exist apparently under all OS (in 
> particular, it was detected on Windows 2000 and Windows XP Pro 2002 SP2 either 
> Chinese version or standard English with Chinese System locale installed.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message