commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Phil Steitz (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MATH-689) Breaking up "MathUtils"
Date Thu, 13 Oct 2011 05:39:11 GMT

    [ https://issues.apache.org/jira/browse/MATH-689?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13126356#comment-13126356
] 

Phil Steitz commented on MATH-689:
----------------------------------

Sorry I missed this before.  Can we change "ArithmeticsUtils" to "ArithmeticUtils."
                
> Breaking up "MathUtils"
> -----------------------
>
>                 Key: MATH-689
>                 URL: https://issues.apache.org/jira/browse/MATH-689
>             Project: Commons Math
>          Issue Type: Task
>            Reporter: Gilles
>            Priority: Trivial
>              Labels: api-change
>             Fix For: 3.0
>
>
> Issue related to this [proposal|http://www.mail-archive.com/dev@commons.apache.org/msg25617.html].
> There seemed to be a global agreement on the following break-up:
> *  Arithmetics (for "addAndCheck", "factorial", "gcd", ...)
> *  Precision (for "equals", "compare", ...)
> *  Binomial (for "binomialCoefficient")
> *  MathArrays (for "linearCombination", "distance", "safeNorm", "sortInPlace", "copyOf",
...)
> I think that "ordinary" mathematical functions ("pow", "cosh", ...) should go into "FastMath"
(if not already available there).
> Those who are willing to work on this issue, please coordinate here.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message