commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gilles (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MATH-663) Remove "getData" in "RealVector" (package "o.a.c.m.linear")
Date Thu, 08 Sep 2011 13:06:09 GMT

    [ https://issues.apache.org/jira/browse/MATH-663?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13100288#comment-13100288
] 

Gilles commented on MATH-663:
-----------------------------

Maybe, maybe not. Keeping "toArray" (in preference to "getData") was to increase similarity
with standard Java classes. As there is no such pull for matrix classes, we might keep the
existing method.


> Remove "getData" in "RealVector" (package "o.a.c.m.linear")
> -----------------------------------------------------------
>
>                 Key: MATH-663
>                 URL: https://issues.apache.org/jira/browse/MATH-663
>             Project: Commons Math
>          Issue Type: Task
>            Reporter: Gilles
>            Assignee: Gilles
>            Priority: Trivial
>              Labels: api-change
>             Fix For: 3.0
>
>
> "getData()" is redundant with "toArray()".

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message