commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gilles (JIRA)" <j...@apache.org>
Subject [jira] [Created] (MATH-656) "isSparse()" method vs marker interfaces
Date Fri, 02 Sep 2011 17:33:10 GMT
"isSparse()" method vs marker interfaces
----------------------------------------

                 Key: MATH-656
                 URL: https://issues.apache.org/jira/browse/MATH-656
             Project: Commons Math
          Issue Type: Improvement
            Reporter: Gilles
            Priority: Trivial
             Fix For: 3.0


>From discussions on the "dev" ML, it seems that it would be advantageous to introduce
a method "isSparse()" in "RealVector" and in "RealMatrix".
For "RealVector", it will make sense to use it to select between "iterator()" and "sparseIterator()"
in methods implemented in that class.
We could then remove the "SparseRealVector" and "SparseRealMatrix" interfaces.


--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message