commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From S├ębastien Brisard (JIRA) <j...@apache.org>
Subject [jira] [Commented] (MATH-653) Rename "AbstractRealVector" to "RealVector"
Date Fri, 02 Sep 2011 06:23:09 GMT

    [ https://issues.apache.org/jira/browse/MATH-653?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13095795#comment-13095795
] 

S├ębastien Brisard commented on MATH-653:
----------------------------------------

OK, I've started to look into the {{DecompositionSolver}}. Unfortunately, the method {{solve(double[])}}
gets called in {{GaussNewtonOptimizer}}. This class makes thorough use of {{double[]}} as
a representation of vectors. There might be a gain in replacing occurences of {{double[]}}
by {{ArrayRealVector}}. This might be like opening Pandora's box, though.
For the time being, I can propose a quick fix for {{GaussNewtonOptimizer}} to call {{solve(RealVector)}}
instead of {{solve(double[])}}, and work on all implementations of {{DecompositionSolver}}
so as to remove {{solve(double[])}}, and keep only {{solve(RealVector)}} (and possibly {{solve(ArrayRealVector)}}).

How do you like that?

> Rename "AbstractRealVector" to "RealVector"
> -------------------------------------------
>
>                 Key: MATH-653
>                 URL: https://issues.apache.org/jira/browse/MATH-653
>             Project: Commons Math
>          Issue Type: Task
>            Reporter: Gilles
>            Assignee: Gilles
>            Priority: Trivial
>             Fix For: 3.0
>
>
> "AbstractRealVector" is the only implementation of the "RealVector" interface.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message