commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sebb (JIRA)" <>
Subject [jira] [Commented] (NET-420) Retrieving files from AS400 FTP systems returns null timestamps in FTPFile.getTimestamp
Date Tue, 30 Aug 2011 15:03:37 GMT


Sebb commented on NET-420:

Your code is using:

bq. conf.setDefaultDateFormatStr("MM/dd/yy HH:mm:ss");

yet the list looks like the following:

bq. -rwxrwxrwx 1 RAMYARAJ 0 22 Aug 25 22:31 file.txt

It's not surprising that the entries are not being parsed.

Try using a date format string that corresponds with the listing output, for example:

conf.setDefaultDateFormatStr("dd MMM yy HH:mm:ss");

> Retrieving files from AS400 FTP systems returns null timestamps in FTPFile.getTimestamp
> ---------------------------------------------------------------------------------------
>                 Key: NET-420
>                 URL:
>             Project: Commons Net
>          Issue Type: Bug
>          Components: FTP
>    Affects Versions: 2.0, 3.0.1
>         Environment: Commons Net 2.0
> FTP System: AS400 systems
>            Reporter: Ramya Rajendiran
>            Priority: Critical
> We are trying to list files from AS400 systems and retrieve the timestamps from these
files using the following code:
> FTPClientConfig conf = new FTPClientConfig(FTPClientConfig.SYST_AS400);
> conf.setDefaultDateFormatStr("MM/dd/yy HH:mm:ss");
> ftpClient.configure(conf); 
> ftpClient.connect(hostName);
> FTPFile[] file = ftpClient.listFiles(remoteFileName);
> Calendar timeStamp = files[0].getTimestamp();
> timeStamp returned is always null.
> I have also tried various setting other parsers.. but that also does not work:
> FTPListParseEngine engine = ftpClient.initiateListParsing("",remoteFileName);
> FTPFile[] files = engine.getNext(25);  
> The LIST command which is used internally in the FTPClient retrieves the timestamps successfully.
However after parsing the FTPFile has a null value for the timestamp field.
> I tried the latest commons net 3.0.1 and the problem still exists.
> Please help us fix this problem. It is critical to us.

This message is automatically generated by JIRA.
For more information on JIRA, see:


View raw message