commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Thomas (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DBCP-350) Problem with DBCP 1.3 /jdk 6 and oracle spatial
Date Thu, 11 Aug 2011 10:47:27 GMT

    [ https://issues.apache.org/jira/browse/DBCP-350?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13083058#comment-13083058
] 

Mark Thomas commented on DBCP-350:
----------------------------------

No, DBCP does not use hibernate. Your application is using hibernate and hibernate is using
DBCP, a version of which is packaged inside Apache Tomcat.

There is no bug in Tomcat or DBCP to fix. The bug - if there is one - in hibernate or possibly
your application.

The hibernate folks are taking the understandable view that this is not a bug in hibernate.
In this case hibernate needs access to the raw connection and it isn't really practical for
hibernate to handle all possible scenarios for what it might need to do to access the raw
connection. Hibernate provides a default mechanism to obtain the raw connection and provides
an extension point for users to provide their own mechanism where the default mechanism doesn't
work.

The application that is using hibernate needs to provide an appropriate implementation of
hibernate's ConnectionFinder.

Yes this is open source but just because you are using DBCP as embedded in Tomcat that does
not make all database problems you come across DBCP or Tomcat bugs. While the problem you
are seeing was triggered by a change to DBCP that still does not make this a DBCP bug. Hibernate
was relying on the raw connection being available which is not a valid assumption in an environment
using connection pooling.

The community has provided you with all the information you need to fix the problem you are
experiencing with your application.

> Problem with DBCP 1.3 /jdk 6 and oracle spatial
> -----------------------------------------------
>
>                 Key: DBCP-350
>                 URL: https://issues.apache.org/jira/browse/DBCP-350
>             Project: Commons Dbcp
>          Issue Type: Bug
>    Affects Versions: 1.3, 1.4
>         Environment: CentOS 5.5 x86_64, Oracle JDK 1.6u22 32bit, Tomcat 5.5.31, ojdbc6.jar
>            Reporter: Nils Hildebrand
>             Fix For: 1.3.1, 1.4.1
>
>
> We have a GIS-application running on Tomcat 5.5. As webserver we are using
> Apache httpd 2.2 connected to tomcat via ajp (mod_proxy_ajp).
> The application worked fine with Tomcat 5.5.28 until we tried to upgrade to Tomcat 5.5.31.
> After the upgrade we get - in certain situations a:
> java.io.IOException: org.hibernatespatial.helper.FinderException: Couldn't get
> at the OracleSpatial Connection object from the PreparedStatement.
> After looking through the Tomcat 5.5 changelogs we stumbled across a change
> made in 5.5.30: Upgrade to DBCP 1.3.
> I can affirm now that the problem is gone when downgrading to DBCP 1.2.2.
> The same problem occurs when using DBCP 1.4.
> It seems something has changed from 1.2.2 to 1.3 that has partially broken Oracle-Locator
operations in dbcp 1.3
> I've seen some bug-reports for dbcp 1.3.1 which point in the same direction (oracle-db-error
lead to java error) - perhaps these are the same problems...

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message