commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gilles (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MATH-653) Rename "AbstractRealVector" to "RealVector"
Date Mon, 29 Aug 2011 02:03:37 GMT

    [ https://issues.apache.org/jira/browse/MATH-653?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13092593#comment-13092593
] 

Gilles commented on MATH-653:
-----------------------------

Removed methods taking a "double[]" arguments from "RealVector" (revision 1162629).

I've left them in "ArrayRealVector"; they seem to make sense there because the "double[]"
is the underlying storage of that class.
Also, they are called within methods that override the base class ones. However, if it is
preferable that subclasses do not contain methods that are not in the base class interface,
we can either
* inline the specialized code and remove the methods, or
* make those methods private.

What do you think?


> Rename "AbstractRealVector" to "RealVector"
> -------------------------------------------
>
>                 Key: MATH-653
>                 URL: https://issues.apache.org/jira/browse/MATH-653
>             Project: Commons Math
>          Issue Type: Task
>            Reporter: Gilles
>            Assignee: Gilles
>            Priority: Trivial
>             Fix For: 3.0
>
>
> "AbstractRealVector" is the only implementation of the "RealVector" interface.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message