commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Elijah Zupancic (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CHAIN-53) Global Update of Chain - Generics, JDK 1.5, Update Dependency Versions
Date Tue, 16 Aug 2011 20:28:27 GMT

     [ https://issues.apache.org/jira/browse/CHAIN-53?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Elijah Zupancic updated CHAIN-53:
---------------------------------

    Description: 
As posted in the mailing list, I've done this work outside of an offical branch.

In this patch:
* Global upgrade to the JDK 1.5
* Added @Override annotations
* Upgraded to the Servlet 2.5 API
* Upgraded to the Faces 2.1 API
* Upgraded to the Portlet 2.0 API
* Upgraded the Maven Parent POM version
* Added generics support to Command so that Command's API looks like:

public interface Command<T extends Context> {
...
   boolean execute(T context) throws Exception;
}

The only incompatibility with the existing API is in: org.apache.commons.chain.web.servlet.ServletHeaderValuesMap
on line 97. Previously the API was returning Set<Entry<String, Enumeration<String>>
when by all indications it actually should have been returning Set<Entry<String, String[]>>.
I believe that I fixed a previously undiscovered bug here.

  was:
As posted in the mailing list, I've done this work outside of an offical branch.

Here is the source:
http://elijah.zupancic.name/projects/commons-chain-v2-proof-of-concept.tar.gz

And here is a diff:

http://elijah.zupancic.name/projects/uber-diff

In this patch:
* Global upgrade to the JDK 1.5
* Added @Override annotations
* Upgraded to the Servlet 2.5 API
* Upgraded to the Faces 2.1 API
* Upgraded to the Portlet 2.0 API
* Upgraded the Maven Parent POM version
* Added generics support to Command so that Command's API looks like:

public interface Command<T extends Context> {
...
   boolean execute(T context) throws Exception;
}

I'm very much new to the ASF and I was advised to file a bug in order to get the process started
for these changes to be integrated.


> Global Update of Chain - Generics, JDK 1.5, Update Dependency Versions
> ----------------------------------------------------------------------
>
>                 Key: CHAIN-53
>                 URL: https://issues.apache.org/jira/browse/CHAIN-53
>             Project: Commons Chain
>          Issue Type: Improvement
>            Reporter: Elijah Zupancic
>              Labels: newbie, patch
>
> As posted in the mailing list, I've done this work outside of an offical branch.
> In this patch:
> * Global upgrade to the JDK 1.5
> * Added @Override annotations
> * Upgraded to the Servlet 2.5 API
> * Upgraded to the Faces 2.1 API
> * Upgraded to the Portlet 2.0 API
> * Upgraded the Maven Parent POM version
> * Added generics support to Command so that Command's API looks like:
> public interface Command<T extends Context> {
> ...
>    boolean execute(T context) throws Exception;
> }
> The only incompatibility with the existing API is in: org.apache.commons.chain.web.servlet.ServletHeaderValuesMap
on line 97. Previously the API was returning Set<Entry<String, Enumeration<String>>
when by all indications it actually should have been returning Set<Entry<String, String[]>>.
I believe that I fixed a previously undiscovered bug here.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message