commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gilles (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MATH-643) Rename RealVector.map* to RealVector.ebe* (mapAdd(...) to ebeAdd(...) and mapAddToSelf(...) to ebeAddToSelf(...) for instance
Date Sun, 07 Aug 2011 20:40:27 GMT

    [ https://issues.apache.org/jira/browse/MATH-643?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13080660#comment-13080660
] 

Gilles commented on MATH-643:
-----------------------------

> ad d to all elemnets of this

This is correct.

> aka. add d element-by-element

Sorry, I think that this does not mean anything.

> map is misleading

This name is used in many languages. It means "apply <the operation> to each element".

> use ebe

As noted already, this is not the same: It means "apply <the operation> to each pair
of elements".

> drop the prefix entirely.

This is incorrect in some cases. What would mean adding a number to an array?


> Rename RealVector.map* to RealVector.ebe* (mapAdd(...) to ebeAdd(...) and mapAddToSelf(...)
to ebeAddToSelf(...) for instance
> -----------------------------------------------------------------------------------------------------------------------------
>
>                 Key: MATH-643
>                 URL: https://issues.apache.org/jira/browse/MATH-643
>             Project: Commons Math
>          Issue Type: Improvement
>    Affects Versions: 3.0
>            Reporter: Arne Plöse
>            Priority: Minor
>
> I think the map* methods have historical names. Today I would prefer ebe as prefix like
ebeMultiply(...).
> This would describe the methods better from a users view.
> If this is a valid issue, I could provide a patch.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message