commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Oliver Heger (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CONFIGURATION-451) commons-beanutils in two different version in dependency tree
Date Wed, 15 Jun 2011 19:48:47 GMT

    [ https://issues.apache.org/jira/browse/CONFIGURATION-451?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13049979#comment-13049979
] 

Oliver Heger commented on CONFIGURATION-451:
--------------------------------------------

Not sure whether I understand your point. There is no need to have both versions of commons-beanutils
in the classpath. The transitive dependency to version 1.7.0 is overridden by the one specified
in the pom. So the maven classpath ends up with only version 1.8 included. Just do a {{mvn
dependency:copy-dependencies}}. This command puts all dependencies currently used in a directory.
There is only the newest version of beanutils contained.

In your project you also should have *only* version 1.8 of beanutils in the classpath. Commons
Configuration is compatible with it. You can use all new features of this version in your
project.

> commons-beanutils in two different version in dependency tree
> -------------------------------------------------------------
>
>                 Key: CONFIGURATION-451
>                 URL: https://issues.apache.org/jira/browse/CONFIGURATION-451
>             Project: Commons Configuration
>          Issue Type: Bug
>          Components: Build
>    Affects Versions: 1.6
>            Reporter: Daniel Bimschas
>            Priority: Minor
>              Labels: build, maven
>
> The Maven dependency tree (mvn dependency:tree) delivers:
> {quote}
> [INFO] |     \- commons-configuration:commons-configuration:jar:1.6:compile
> [INFO] |        +- commons-collections:commons-collections:jar:3.2.1:compile
> [INFO] |        +- commons-logging:commons-logging:jar:1.1.1:compile
> [INFO] |        +- commons-digester:commons-digester:jar:1.8:compile
> [INFO] |        |  \- commons-beanutils:commons-beanutils:jar:1.7.0:compile
> [INFO] |        \- commons-beanutils:commons-beanutils-core:jar:1.8.0:compile
> {quote}
> There is two times the commons-beanutils package with two different versions which can
potentially cause problems during runtime as it is not clear which version is first in the
classpath.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message