commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Luc Maisonobe (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MATH-573) in ArrayFielVector i.e. subtract calls wrong constructor
Date Sun, 15 May 2011 13:23:47 GMT

    [ https://issues.apache.org/jira/browse/MATH-573?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13033681#comment-13033681
] 

Luc Maisonobe commented on MATH-573:
------------------------------------

Don't worry Arne, I'm happy you point out mistakes in our code.

I seem to have forgotten committing the changes I made yesterday about specifying field wherever
possible. It's in the repository now.

Doing some benchmarks to check if we should remove or keep different implementations would
be a good thing. Would you try to give it a try and report your results, preferably opening
a new Jira issue ?

I found checkDimension only in MultivariateSummaryStatistics and checkdimension (small case
"d") only in tests. Where did you see other use ?

> in ArrayFielVector i.e. subtract calls wrong constructor
> --------------------------------------------------------
>
>                 Key: MATH-573
>                 URL: https://issues.apache.org/jira/browse/MATH-573
>             Project: Commons Math
>          Issue Type: Bug
>    Affects Versions: 3.0
>            Reporter: Arne Plöse
>            Priority: Minor
>             Fix For: 3.0
>
>
> I.E. subtract calls
> "return new ArrayFieldVector<T>(out)" this constructor clones the array...
> "return new ArrayFieldVector<T>(field, out, false)" would be better (preserving
field as well)

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message