commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Arne Plöse (JIRA) <j...@apache.org>
Subject [jira] [Commented] (MATH-570) Change some constructors of ArrayFieldVector to accept FieldVector
Date Tue, 10 May 2011 07:00:03 GMT

    [ https://issues.apache.org/jira/browse/MATH-570?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13031061#comment-13031061
] 

Arne Plöse commented on MATH-570:
---------------------------------

OK I understand, but I don't want to have a param ArrayFieldvector<T> in the constructor.
Fieldvector<T> as a parameter is in my opinion enough.

on can do a if (v instance of ArrayFieldVector) {
"copy or wrap? v.data directly"
} else {
"use v.getData"
}

This would be efficient code and gives the opportunity to have FieldVector as parameter.

> Change some constructors of ArrayFieldVector to accept FieldVector
> ------------------------------------------------------------------
>
>                 Key: MATH-570
>                 URL: https://issues.apache.org/jira/browse/MATH-570
>             Project: Commons Math
>          Issue Type: Improvement
>    Affects Versions: 3.0
>            Reporter: Arne Plöse
>            Priority: Minor
>
> the constructor     public ArrayFieldVector(T[] v1, ArrayFieldVector<T> v2) {
>  ... 
> }
> takes an ArrayFieldVector.
> but the same can be easier archieved with this 
>     public ArrayFieldVector(T[] v1, FieldVector<T> v2) {
>         this(v1, v2 == null ? null : v2.getData());
>     }
> this goes for all other constructors...
> P.S. I donk know if copying the data in getData is an issue ... for this the named constructor
may make sense...

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message