commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ole Ersoy (JIRA)" <>
Subject [jira] Commented: (MATH-512) "GaussianFitter" could inherit from "CurveFitter"
Date Fri, 18 Feb 2011 16:04:38 GMT


Ole Ersoy commented on MATH-512:

OK - I cleaned up the formatting.  It still says there's an illegal tab on line 80.  Is there
a commons math formatting profile that I should be using, or should I just create a new one
that only uses spaces instead of tabs?

> "GaussianFitter" could inherit from "CurveFitter"
> -------------------------------------------------
>                 Key: MATH-512
>                 URL:
>             Project: Commons Math
>          Issue Type: Improvement
>            Reporter: Gilles
>            Priority: Minor
>             Fix For: 3.0
>         Attachments: GaussianFitter.patch, GaussianFitter.patch, GaussianFitter.patch,
GaussianFitterTest.patch, ParametricGaussianFunctionTest.patch
> Currently, the "GaussianFitter" class contains a "CurveFitter" instance (and delegates
most method calls to it) for the sake of being able to return a "GaussianFunction" instance
(from the call to the "fit" method).
> I think that it would clearer (in the context of the "fitting" package) that "fit" returns
an array of doubles (as "CurveFitter" does). The user can then easily create a "Gaussian"
function object, if needed.
> [Also, note that the "GaussianFitter" actually fits the sum of a constant and a Gaussian
function; thus the name is slightly misleading IMO.]
> I also think that "ParametricGaussianFunction" and "GaussianParametersGuesser" should
become inner classes of "GaussianFitter" (as this makes it clear what their use is).

This message is automatically generated by JIRA.
For more information on JIRA, see:


View raw message