commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gilles (JIRA)" <>
Subject [jira] Commented: (MATH-512) "GaussianFitter" could inherit from "CurveFitter"
Date Fri, 18 Feb 2011 16:41:38 GMT


Gilles commented on MATH-512:

I did some more formatting clean-up. Also removed a trivial method that was used only once.
I don't know about profiles (I use "emacs" with some configuration that automatically indents
the code with the appropriate amount of space characters).

> "GaussianFitter" could inherit from "CurveFitter"
> -------------------------------------------------
>                 Key: MATH-512
>                 URL:
>             Project: Commons Math
>          Issue Type: Improvement
>            Reporter: Gilles
>            Priority: Minor
>             Fix For: 3.0
>         Attachments: GaussianFitter.patch, GaussianFitter.patch, GaussianFitter.patch,
GaussianFitterTest.patch, ParametricGaussianFunctionTest.patch
> Currently, the "GaussianFitter" class contains a "CurveFitter" instance (and delegates
most method calls to it) for the sake of being able to return a "GaussianFunction" instance
(from the call to the "fit" method).
> I think that it would clearer (in the context of the "fitting" package) that "fit" returns
an array of doubles (as "CurveFitter" does). The user can then easily create a "Gaussian"
function object, if needed.
> [Also, note that the "GaussianFitter" actually fits the sum of a constant and a Gaussian
function; thus the name is slightly misleading IMO.]
> I also think that "ParametricGaussianFunction" and "GaussianParametersGuesser" should
become inner classes of "GaussianFitter" (as this makes it clear what their use is).

This message is automatically generated by JIRA.
For more information on JIRA, see:


View raw message