commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gilles (JIRA)" <>
Subject [jira] Commented: (MATH-514) Replace the "ParametricGaussianFunction" class
Date Wed, 16 Feb 2011 22:53:24 GMT


Gilles commented on MATH-514:

A "Parametric" inner is class has been defined in class "Gaussian" (in revision 1071430).

The "ParametricGaussianFunction" will not be deleted until MATH-512 is resolved (among other
things by using "Gaussian.Parametric" instead of "ParametricGaussianFunction").

> Replace the "ParametricGaussianFunction" class
> ----------------------------------------------
>                 Key: MATH-514
>                 URL:
>             Project: Commons Math
>          Issue Type: Improvement
>            Reporter: Gilles
>            Assignee: Gilles
>            Priority: Minor
>              Labels: api-change
>             Fix For: 3.0
> The "ParametricGaussianFunction" is defined in package "optimization.fitting" whereas
it is not specific to the fitting concept. It would be more logical to have that functionality
provided as an inner class of the "Gaussian" class (in package "analysis.function").
> Moreover, no unit test in "ParametricGaussianFunctionTest" actually tests the code of
the "value" and "gradient" methods, while tests in that class duplicate some of the tests
in "GaussianFitterTest" (thus testing the fitting code instead of the function).

This message is automatically generated by JIRA.
For more information on JIRA, see:


View raw message