commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gilles (JIRA)" <j...@apache.org>
Subject [jira] Created: (MATH-512) "GaussianFitter" could inherit from "CurveFitter"
Date Tue, 15 Feb 2011 09:57:57 GMT
"GaussianFitter" could inherit from "CurveFitter"
-------------------------------------------------

                 Key: MATH-512
                 URL: https://issues.apache.org/jira/browse/MATH-512
             Project: Commons Math
          Issue Type: Improvement
            Reporter: Gilles
            Priority: Minor
             Fix For: 3.0


Currently, the "GaussianFitter" class contains a "CurveFitter" instance (and delegates most
method calls to it) for the sake of being able to return a "GaussianFunction" instance (from
the call to the "fit" method).
I think that it would clearer (in the context of the "fitting" package) that "fit" returns
an array of doubles (as "CurveFitter" does). The user can then easily create a "Gaussian"
function object, if needed.
[Also, note that the "GaussianFitter" actually fits the sum of a constant and a Gaussian function;
thus the name is slightly misleading IMO.]
I also think that "ParametricGaussianFunction" and "GaussianParametersGuesser" should become
inner classes of "GaussianFitter" (as this makes it clear what their use is).


-- 
This message is automatically generated by JIRA.
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message