commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gilles (JIRA)" <j...@apache.org>
Subject [jira] Created: (MATH-513) Moving the "ParametricRealFunction" interface
Date Wed, 16 Feb 2011 13:33:57 GMT
Moving the "ParametricRealFunction" interface
---------------------------------------------

                 Key: MATH-513
                 URL: https://issues.apache.org/jira/browse/MATH-513
             Project: Commons Math
          Issue Type: Improvement
            Reporter: Gilles
            Assignee: Gilles
            Priority: Minor
             Fix For: 3.0


I'm suggesting that the "ParametricRealFunction" interface be moved from package "optimization.fitting"
to the package "analysis" where other similar function interfaces (e.g. "UnivariateRealFunction"
are defined). On the way it should also be renamed to "ParametricUnivariateRealFunction" (so
as to allow the definition of the multivariate counterpart).


-- 
This message is automatically generated by JIRA.
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message