commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gilles (JIRA)" <>
Subject [jira] Created: (MATH-514) Replace the "ParametricGaussianFunction" class
Date Wed, 16 Feb 2011 15:11:57 GMT
Replace the "ParametricGaussianFunction" class

                 Key: MATH-514
             Project: Commons Math
          Issue Type: Improvement
            Reporter: Gilles
            Assignee: Gilles
            Priority: Minor
             Fix For: 3.0

The "ParametricGaussianFunction" is defined in package "optimization.fitting" whereas it is
not specific to the fitting concept. It would be more logical to have that functionality provided
as an inner class of the "Gaussian" class (in package "analysis.function").

Moreover, no unit test in "ParametricGaussianFunctionTest" actually tests the code of the
"value" and "gradient" methods, while tests in that class duplicate some of the tests in "GaussianFitterTest"
(thus testing the fitting code instead of the function).

This message is automatically generated by JIRA.
For more information on JIRA, see:


View raw message