commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gilles (JIRA)" <j...@apache.org>
Subject [jira] Commented: (MATH-503) Common mathematical functions
Date Thu, 24 Feb 2011 15:23:38 GMT

    [ https://issues.apache.org/jira/browse/MATH-503?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12998895#comment-12998895
] 

Gilles commented on MATH-503:
-----------------------------

I'd favour the name "Logit" and make the default constructor create the usual logit function,
i.e. with a = 0 and b = 1. IMO, something like 
{noformat}
  ScaledLogit logit = new ScaledLogit();
  ScaledLogit scaledLogit = new ScaledLogit(a, b);
{noformat}
seems less clear than
{noformat}
  Logit logit = new Logit();
  Logit scaledLogit = new Logit(a, b);
{noformat}


> Common mathematical functions
> -----------------------------
>
>                 Key: MATH-503
>                 URL: https://issues.apache.org/jira/browse/MATH-503
>             Project: Commons Math
>          Issue Type: Wish
>            Reporter: Gilles
>            Assignee: Gilles
>            Priority: Minor
>             Fix For: 3.0
>
>
> I propose to add some functions in the package {{analysis.function}}:
> * [Generalized logistic|http://en.wikipedia.org/wiki/Generalised_logistic_function]
> * [Step|http://en.wikipedia.org/wiki/Step_function]
> * [Gaussian|http://en.wikipedia.org/wiki/Gaussian_function]
> Other suggestions?

-- 
This message is automatically generated by JIRA.
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message