commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Thomas (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DBCP-350) Problem with DBCP 1.3 /jdk 6 and oracle spatial
Date Wed, 08 Dec 2010 09:51:01 GMT

    [ https://issues.apache.org/jira/browse/DBCP-350?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12969261#action_12969261
] 

Mark Thomas commented on DBCP-350:
----------------------------------

I believe there is a configuration problem.

The conection pools are using the deprecated "oracle.jdbc.OracleDriver" that return connections
of type oracle.jdbc.OracleConnection. However, the HibernateSpatial (trunk at least) is looking
for the newer oracle.jdbc.driver.OracleConnection which are returned when using the newer
oracle.jdbc.driver.OracleDriver. I suspect switching your connection pools to use oracle.jdbc.driver.OracleDriver
will fix this issue.

> Problem with DBCP 1.3 /jdk 6 and oracle spatial
> -----------------------------------------------
>
>                 Key: DBCP-350
>                 URL: https://issues.apache.org/jira/browse/DBCP-350
>             Project: Commons Dbcp
>          Issue Type: Bug
>    Affects Versions: 1.3, 1.4
>         Environment: CentOS 5.5 x86_64, Oracle JDK 1.6u22 32bit, Tomcat 5.5.31, ojdbc6.jar
>            Reporter: Nils Hildebrand
>
> We have a GIS-application running on Tomcat 5.5. As webserver we are using
> Apache httpd 2.2 connected to tomcat via ajp (mod_proxy_ajp).
> The application worked fine with Tomcat 5.5.28 until we tried to upgrade to Tomcat 5.5.31.
> After the upgrade we get - in certain situations a:
> java.io.IOException: org.hibernatespatial.helper.FinderException: Couldn't get
> at the OracleSpatial Connection object from the PreparedStatement.
> After looking through the Tomcat 5.5 changelogs we stumbled across a change
> made in 5.5.30: Upgrade to DBCP 1.3.
> I can affirm now that the problem is gone when downgrading to DBCP 1.2.2.
> The same problem occurs when using DBCP 1.4.
> It seems something has changed from 1.2.2 to 1.3 that has partially broken Oracle-Locator
operations in dbcp 1.3
> I've seen some bug-reports for dbcp 1.3.1 which point in the same direction (oracle-db-error
lead to java error) - perhaps these are the same problems...

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message