commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Luc Maisonobe (JIRA)" <j...@apache.org>
Subject [jira] Updated: (MATH-381) inconsistency for methods names within StepInterpolator and StepInterpolatorWithJacobians
Date Mon, 23 Aug 2010 07:28:17 GMT

     [ https://issues.apache.org/jira/browse/MATH-381?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Luc Maisonobe updated MATH-381:
-------------------------------

    Fix Version/s: 3.0
                       (was: 2.2)

Yes, I pushed this to 3.0.
However, the refactoring proposed in my previous comment should be done for 2.2.
I'm working on it.

> inconsistency for methods names within StepInterpolator and StepInterpolatorWithJacobians
> -----------------------------------------------------------------------------------------
>
>                 Key: MATH-381
>                 URL: https://issues.apache.org/jira/browse/MATH-381
>             Project: Commons Math
>          Issue Type: Bug
>    Affects Versions: 2.1
>            Reporter: Pascal Parraud
>            Priority: Trivial
>             Fix For: 3.0
>
>
> There is some inconstency in methods naming :
> getInterpolatedY and getInterpolatedYDot in StepInterpolatorWithJacobians do the same
as getInterpolatedState and getInterpolatedDerivatives in StepInterpolator, so it will be
better if they would have the same name.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message