commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Luc Maisonobe (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (MATH-399) Incorrect javadoc for RealVector subtract method
Date Thu, 29 Jul 2010 19:30:17 GMT

     [ https://issues.apache.org/jira/browse/MATH-399?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Luc Maisonobe resolved MATH-399.
--------------------------------

    Resolution: Fixed

fixed in subversion repository as of r980544.
thanks for reporting this.

On a side note, it really seems subtract is the proper spelling whereas substract is a common
misspelling. I am not a native english speaker, so I checked several references.

> Incorrect javadoc for RealVector subtract method
> ------------------------------------------------
>
>                 Key: MATH-399
>                 URL: https://issues.apache.org/jira/browse/MATH-399
>             Project: Commons Math
>          Issue Type: Bug
>            Reporter: Julien Ruiz
>            Priority: Minor
>   Original Estimate: 4h
>  Remaining Estimate: 4h
>
> subtract method decription is :
> 069         * Compute this minus v.
> 070         * @param v vector to be subtracted
> 071         * @return this + v
> 072         * @throws IllegalArgumentException if v is not the same size as this
> 073         */
> (...)
> 080         * @return this + v
> Should be : return this - v
> Besides, method might be renamed to substract .

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message