commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Henri Yandell (JIRA)" <j...@apache.org>
Subject [jira] Closed: (COLLECTIONS-337) BasicPredicateTestBase.assertFalse & BasicPredicateTestBase.assertTrue methods have confusing names
Date Sat, 19 Jun 2010 19:45:23 GMT

     [ https://issues.apache.org/jira/browse/COLLECTIONS-337?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Henri Yandell closed COLLECTIONS-337.
-------------------------------------

    Resolution: Won't Fix

I don't see why they would have to override the method signatures in the JUnit superclass.
Method overloading is not abnormal.

> BasicPredicateTestBase.assertFalse & BasicPredicateTestBase.assertTrue methods have
confusing names
> ---------------------------------------------------------------------------------------------------
>
>                 Key: COLLECTIONS-337
>                 URL: https://issues.apache.org/jira/browse/COLLECTIONS-337
>             Project: Commons Collections
>          Issue Type: Bug
>            Reporter: Sebb
>
> BasicPredicateTestBase.assertFalse & BasicPredicateTestBase.assertTrue methods have
confusing names - they are the same as the JUnit names, but don't override them.
> Of course it's still possible to use the JUnit versions of the methods, but the code
is harder to understand.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message