commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Phil Steitz (JIRA)" <>
Subject [jira] Commented: (MATH-370) NaN in "equals" methods
Date Tue, 11 May 2010 10:16:42 GMT


Phil Steitz commented on MATH-370:

I am fine with deprecating and changing the name of MathUtils.equals(double, double) to "equalsIncludingNaN"
or "equalsN".   I see no reason to change the names or modify the behavior of any of the other
equals methods in MathUtils.

> NaN in "equals" methods
> -----------------------
>                 Key: MATH-370
>                 URL:
>             Project: Commons Math
>          Issue Type: Bug
>            Reporter: Gilles
>            Priority: Minor
> In "MathUtils", some "equals" methods will return true if both argument are NaN.
> Unless I'm mistaken, this contradicts the IEEE standard.
> If nobody objects, I'm going to make the changes.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message