commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sebb (JIRA)" <j...@apache.org>
Subject [jira] Commented: (CODEC-100) Please rename class StringUtils to StringCodec or someting (because there is class with same name in commons-lang)
Date Tue, 18 May 2010 15:43:44 GMT

    [ https://issues.apache.org/jira/browse/CODEC-100?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12868688#action_12868688
] 

Sebb commented on CODEC-100:
----------------------------

-1 to the proposed change.
I agree with Gregory.
A lot of projects also have Utils or Tools classes.

> Please rename class StringUtils to StringCodec or someting (because there is class with
same name in commons-lang)
> ------------------------------------------------------------------------------------------------------------------
>
>                 Key: CODEC-100
>                 URL: https://issues.apache.org/jira/browse/CODEC-100
>             Project: Commons Codec
>          Issue Type: Improvement
>    Affects Versions: 1.4
>            Reporter: Dmitry Mamonov
>
> Duplicate class name in libraries "codec" and "lang":
> org.apache.commons.lang.StringUtils
> org.apache.commons.codec.binary.StringUtils

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message