commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] Updated: (POOL-160) OSGi Export-Package statement is not correct
Date Thu, 25 Feb 2010 10:31:27 GMT

     [ https://issues.apache.org/jira/browse/POOL-160?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jean-Baptiste Onofré updated POOL-160:
--------------------------------------

    Attachment: POOL-160.patch

Patch which correct the issue with deployment result on Karaf 1.2.0:

karaf@root> osgi:install mvn:commons-pool/commons-pool/1.5.5-SNAPSHOT
Bundle ID: 32
karaf@root> osgi:start 32
karaf@root> packages:

packages:exports    packages:imports
karaf@root> packages:exports 32
Commons Pool (32): org.apache.commons.pool.impl; version=1.5.5.SNAPSHOT
Commons Pool (32): org.apache.commons.pool; version=1.5.5.SNAPSHOT
karaf@root> packages:

packages:exports    packages:imports
karaf@root> packages:imports 32
Commons Pool (32): No active imported packages.
karaf@root> osgi:headers 32

Commons Pool (32)
-----------------
Archiver-Version = Plexus Archiver
Bnd-LastModified = 1267093353630
Build-Jdk = 1.5.0_14
Built-By = jb
Bundle-Description = Commons Object Pooling Library
Bundle-DocURL = http://commons.apache.org/pool/
Bundle-License = http://www.apache.org/licenses/LICENSE-2.0.txt
Bundle-ManifestVersion = 2
Bundle-Name = Commons Pool
Bundle-SymbolicName = org.apache.commons.pool
Bundle-Vendor = The Apache Software Foundation
Bundle-Version = 1.5.5.SNAPSHOT
Created-By = 1.5.0_14 (Sun Microsystems Inc.)
Export-Package = org.apache.commons.pool.impl;version="1.5.5.SNAPSHOT",org.apache.commons.pool;version="1.5.5.SNAPSHOT"
Ignore-Package = org.apache.commons.pool.impl,org.apache.commons.pool
Implementation-Title = Commons Pool
Implementation-Vendor = The Apache Software Foundation
Implementation-Vendor-Id = org.apache
Implementation-Version = 1.5.5-SNAPSHOT
Manifest-Version = 1.0
Specification-Title = Commons Pool
Specification-Vendor = The Apache Software Foundation
Specification-Version = 1.5.5-SNAPSHOT
Tool = Bnd-0.0.238
X-Compile-Source-JDK = 1.3
X-Compile-Target-JDK = 1.3
karaf@root> 


> OSGi Export-Package statement is not correct
> --------------------------------------------
>
>                 Key: POOL-160
>                 URL: https://issues.apache.org/jira/browse/POOL-160
>             Project: Commons Pool
>          Issue Type: Bug
>    Affects Versions: 1.4, 1.5, 1.5.1, 1.5.2, 1.5.3, 1.5.4
>            Reporter: Jean-Baptiste Onofré
>             Fix For: 1.5.5
>
>         Attachments: POOL-160.patch
>
>
> Currently, the Export-Package statement is extended from the commons-parent POM (version
12).
> By default, the Export-Package is set to * which is not correct when you try to deploy
several commons-pool version in the OSGi version.
> FYI, you can see the workaround used in ServiceMix:
> https://issues.apache.org/activemq/browse/SMX4-491

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message