commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jean-Baptiste Onofré (JIRA) <j...@apache.org>
Subject [jira] Created: (POOL-160) OSGi Export-Package statement is not correct
Date Thu, 25 Feb 2010 10:29:27 GMT
OSGi Export-Package statement is not correct
--------------------------------------------

                 Key: POOL-160
                 URL: https://issues.apache.org/jira/browse/POOL-160
             Project: Commons Pool
          Issue Type: Bug
    Affects Versions: 1.5.4, 1.5.3, 1.5.2, 1.5.1, 1.5, 1.4
            Reporter: Jean-Baptiste Onofré
             Fix For: 1.5.5


Currently, the Export-Package statement is extended from the commons-parent POM (version 12).
By default, the Export-Package is set to * which is not correct when you try to deploy several
commons-pool version in the OSGi version.

FYI, you can see the workaround used in ServiceMix:
https://issues.apache.org/activemq/browse/SMX4-491

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message