commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Oliver Heger (JIRA)" <j...@apache.org>
Subject [jira] Commented: (CONFIGURATION-402) Switch to JDK 1.4 as minimum required JDK
Date Sun, 03 Jan 2010 18:15:54 GMT

    [ https://issues.apache.org/jira/browse/CONFIGURATION-402?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12796009#action_12796009
] 

Oliver Heger commented on CONFIGURATION-402:
--------------------------------------------

It may be possible to drop the dependency to commons collections, too. The most classes we
use from [collections] are ordered maps or sets. JDK 1.4 provides replacements for them.

In the configuration2 branch the dependency to [collections] has already been removed.

> Switch to JDK 1.4 as minimum required JDK
> -----------------------------------------
>
>                 Key: CONFIGURATION-402
>                 URL: https://issues.apache.org/jira/browse/CONFIGURATION-402
>             Project: Commons Configuration
>          Issue Type: Improvement
>    Affects Versions: 1.6
>            Reporter: Oliver Heger
>            Priority: Minor
>             Fix For: 1.7
>
>
> Because JDK 1.3 has reached its EOL a long time ago, support for this JDK can now be
dropped in the 1.x series. This simplifies the creation of new releases and also the build
environment. Also, some new features introduced with JDK 1.4 can now be used, e.g. regular
expressions.
> Changing the minimum required JDK version involves some updates of the documentation,
too.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message