commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Henri Yandell (JIRA)" <j...@apache.org>
Subject [jira] Closed: (LANG-420) Rename ObjectUtils.toString() to asString().
Date Tue, 20 Oct 2009 05:50:59 GMT

     [ https://issues.apache.org/jira/browse/LANG-420?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Henri Yandell closed LANG-420.
------------------------------

    Resolution: Won't Fix

Resolving again as WONTFIX.

I definitely don't see a need to rename the method from toString(). It could be argued that
there could be an alias method of asString() to provide a workaround, but I don't see why
ObjectUtils.toString is such a terrible workaround.

> Rename ObjectUtils.toString() to asString().
> --------------------------------------------
>
>                 Key: LANG-420
>                 URL: https://issues.apache.org/jira/browse/LANG-420
>             Project: Commons Lang
>          Issue Type: Improvement
>    Affects Versions: 2.3
>            Reporter: Stephen Kestle
>            Priority: Trivial
>             Fix For: 3.0
>
>
> With Java 5 static method inlining, methods do not require class qualifying *unless*
the class already has the method.
> For this reason, ObjectUtlis.toString() cannot be inlined to toString(), as Object has
a toString() method.  
> It would be nice for it to have a name that could be statically imported, such as asString.
 This would follow the naming convention of Arrays.asList()
> Note that this DOES NOT need a java 5 version of lang.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message