commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Charles Matthew Chen (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (SANSELAN-29) SanselanGuessFormatTest & SanselanTestConstants use Java 1.5 method String.replace(CharSequence, CharSequence)
Date Sat, 12 Sep 2009 20:44:57 GMT

     [ https://issues.apache.org/jira/browse/SANSELAN-29?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Charles Matthew Chen resolved SANSELAN-29.
------------------------------------------

    Resolution: Fixed

Fixed this issue with revisions 814232 & 814232.
Just switched from developing on Windows to a MacBook Pro.  Eclipse on Mac doesn't enforce
the 1.4 source compatibility if you don't have a 1.4 jre installed, and Mac 1.4 JDK won't
install on Snow Leopard.  Is there a workaround for this issue?
Thanks for catching this, Sebb.


> SanselanGuessFormatTest & SanselanTestConstants use Java 1.5 method String.replace(CharSequence,
CharSequence)
> --------------------------------------------------------------------------------------------------------------
>
>                 Key: SANSELAN-29
>                 URL: https://issues.apache.org/jira/browse/SANSELAN-29
>             Project: Commons Sanselan
>          Issue Type: Bug
>            Reporter: Sebb
>
> SanselanGuessFormatTest & SanselanTestConstants use the Java 1.5 method String.replace(CharSequence
target, CharSequence replacement); however pom.xml says that the code is intended for Java
1.4.
> These are the only Java 1.5 methods currently.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message