commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Julius Davies (JIRA)" <j...@apache.org>
Subject [jira] Created: (CODEC-86) Rename method to Base64.encodeBase64ToString()
Date Thu, 06 Aug 2009 00:13:14 GMT
Rename method to Base64.encodeBase64ToString()
----------------------------------------------

                 Key: CODEC-86
                 URL: https://issues.apache.org/jira/browse/CODEC-86
             Project: Commons Codec
          Issue Type: Improvement
    Affects Versions: 1.4
            Reporter: Julius Davies
            Priority: Trivial
             Fix For: 1.4
         Attachments: codec86.patch

I'm having second thoughts on two method names for CODEC-59.  Here's what it currently looks
like:

Base64.encodeBase64String(byte[] binaryData)
Base64.encodeBase64URLSafeString(byte[] binaryData)

http://juliusdavies.ca/codec/base64String.png
(screenshot from IntelliJ 7, 15KB, 760x187)


I'm wondering if the word "To" should be inserted there?  As in "ToString":

Base64.encodeBase64ToString(byte[] binaryData)
Base64.encodeBase64URLSafeToString(byte[] binaryData)

http://juliusdavies.ca/codec/base64ToString.png
(screenshot from IntelliJ 7, 14KB, 736x162)


Sorry about this inane niggling.  I just thought it's either now or
never!  Any one else have opinions about this extremely minor cosmetic
point?



-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message