commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Henri Yandell (JIRA)" <j...@apache.org>
Subject [jira] Commented: (LANG-420) Rename ObjectUtils.toString() to asString().
Date Thu, 13 Aug 2009 09:17:14 GMT

    [ https://issues.apache.org/jira/browse/LANG-420?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12742776#action_12742776
] 

Henri Yandell commented on LANG-420:
------------------------------------

Looks intentional. I'm guessing this is "A static-import-on-demand declaration never causes
any other declaration to be shadowed." in 7.5.4 of the JLS:

http://java.sun.com/docs/books/jls/third_edition/html/packages.html#94114

> Rename ObjectUtils.toString() to asString().
> --------------------------------------------
>
>                 Key: LANG-420
>                 URL: https://issues.apache.org/jira/browse/LANG-420
>             Project: Commons Lang
>          Issue Type: Improvement
>    Affects Versions: 2.3
>            Reporter: Stephen Kestle
>            Priority: Trivial
>             Fix For: 3.0
>
>
> With Java 5 static method inlining, methods do not require class qualifying *unless*
the class already has the method.
> For this reason, ObjectUtlis.toString() cannot be inlined to toString(), as Object has
a toString() method.  
> It would be nice for it to have a name that could be statically imported, such as asString.
 This would follow the naming convention of Arrays.asList()
> Note that this DOES NOT need a java 5 version of lang.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message